Failed to connect to server VNC console in Openstack

Failed to connect to server VNC console in Openstack

Date posted : 12/04/2019

In this post, we’re going to explain about how to resolve vnc console error in Openstack horizon dashboard.

This happens because there is no controller ip mentioned in nova configuration file. We need to add below lines in order to resolve the issue.

Login to compute node, edit /etc/nova/nova.conf file

vncserver_proxyclient_address=192.168.1.5

Here 192.168.1.5 is the public ip address of compute node. If you are running multiple compute node, you need to add its own ip in nova.conf file

Now you can restart compute service

systemctl restart openstack-nova-compute.service

Thanks for using pheonix solutions.

You find this tutorial helpful? Share with your friends to keep it alive.

admin

Our team has expertise across software and web development, WordPress, e-commerce, mobile applications, UI/UX, cloud and infrastructure, DevOps, CI/CD, API integration, security, testing, automation, and technical support. The team also works with AI-based software solutions, LLMs, AI workflows, AI agents, and intelligent application development to help businesses automate processes and build smarter digital solutions. We focus on developing, deploying, maintaining, and optimising secure, scalable, and reliable technology solutions while helping businesses adopt modern technologies and drive digital transformation.

Leave a Reply

Scroll to Top